assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

AUAudioFilePlayer bug


  • Beta Gold

    Hi All,

    In AUAudioFilePlayer, Output position is not accurate. When playing a whole file, the end of the file is always around 91-92 of the output position.

    When changing play start to another value than 0, the  moving playhead of the player goes "outside of the actor" at the end of the file whhen playing.

    Tested with AIFF and WAV on OSX10.11.6 - Isadora 2.5.2

    Best

    Philippe



  • @fifou said:

    the player goes "outside of the actor

    I have seen things like this when the Scene Editor is either zoomed in or out.

    Regards 

    Bonemap  



  • @fifou 

    I am not able to recreate this problem with two test files, one 0:50 in length, the other 1:11.1. Are you playing very long files? If so, how long?

    What is the sample rate of the files?

    Does the sample rate of the output device match the file sample rate above? (This shouldn't need to match, but I am asking so we can sort out the bug.) 

    Here's a test patch I made that reports the time based on the media time to percent.

    Best Wishes,
    Mark

    audio-file-player-time-test.izz



  • Are you by any chance using an Motu interface?


  • Beta Gold

    I found it !

    The culprit is 48KHz files.

    44,1KHz files behave ok.

    @ Mark : Thanks for the media percent to time user actor.

    Extra request : I you dig into AUAudioFilePlayer's code, is it easy for you to add an EndLoop Trigger output, it would be sooooooo useful.

    @Fred : No, I'm using internal soundcard

    All the best

    Philippe



  • @fifou said:

    The culprit is 48KHz files.

     OK, will investigate.


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.