assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

alpha masking 3 layers



  • Hello folks,

    i'm trying to get my head around the Alpha Mask to create an effect, but can't seem to get things patched together properly to achieve the desired result.

    basically, i want to put a live performer into a photograph of the White House Press Room, so I have the full photo as a background, the podium cut out in Photoshop, (sitting on a transparent Alpha background) as a foreground, and I have a Chroma Key setup to remove the performer from a green background and place them on a transparent background.

    (does this make sense?)

    what I need to find out is how to layer things up so that the performer is cleanly over the full photo background, and the podium image is cleanly over the performer. Any ideas?

    John


  • Beta Gold

    Does this help ?

    I have no clean background so I did the chroma on my blue sweatshirt...

    The red background color should be your background image

    The yellow shape should be your foreground image.

    Of course the quality of the chroma keying strongly depends on your image quality ( camera, but also lighting etc... )

    Best

    Mehdi



  • Hi Mehdi.

    I tried the layering Projectors thing, but can't get it to work. everything is either opaque or additive, changing layer doesn't seem to affect the outcome. i've never had any luck with layers - what am i doing wrong?

    (using a Shapes to simulate the performer on alpha)

    john



  • @dbini said:

    layering Projectors

     Did you try changing the blend mode of the projectors above the background to 'transparent'? In your screengrab the blend mode is set to 'additive'.

    Here is a patch that demonstrates layers using 3D quad actors instead of projectors - 2.5D Layers

    regards

    bonemap



  • yeah - tried all settings, in the projector and also in IzzyMap. i got a slightly better result with the Layer 1 Projector set to Transparent (the orange Shape is solid)

    maybe my problem is with the Alpha of the top layer?? the file is a png that looks transparent in Photoshop. how can i test the transparency in Isadora? (ive tried changing the alpha type using the Alpha tool actor)



  • and @bonemap - i'm not seeing transparency in the output of your 2.5D layers patch either!!! is there a global setting somewhere?



  • Hi John,

    your top layer should definately be set to transparent. The PNG file from photoshop might be the problem.

    best wishes

    bonemap



  • @dbini said:

    not seeing transparency in the output

     That sounds strange, I have no idea why. How are you previewing the patches? 

    best wishes

    bonemap



  • force stage preview gives me this: 



  • Hi John,

    I have had some issues with PNG files in the past but it has been intermittent. Have you tried restarting your machine? Another option is to try a .psd photoshop file for your transparent top layer.

    best wishes

    bonemap



  • Hello Bonemap,

    the psd appears with the transparent area as white, the png has it looking black.

    i have had issues with transparency in Isadora before, most notably when texture-mapping 3D Particles - some of them end up opaque and some stay additive or transparent, but I couldn't work out what was going wrong....

    going to try a reboot now.....



  • Hi,

    There is this thread

    where @mark suggests using "the FFGLPremultiply actor after the Picture Player and before any other actors".

    cheers

    bonemap



  • thanks for your suggestion bonemap, but, unfortunately, that hasn't helped


  • Beta Gold

    @dbini : would you post a patch with your 2 images that I can try it here in the same conditions as you ?

    Best

    Mehdi



  • here it all is: press room.izz + white-house-press-briefing-roomALPHA1.png

    (other files are not uploading, but the offending png is here)



  • (the image files are large because i don't yet know the resolution of the projector - i'm going to scale them down when i get in the studio on Thursday)

    john



  • I found a fix! i set the Video Image Processing preference to Smallest, rather than Default and it works. (although i don't know why it works, i'm glad it is solved)

    also: i used smaller versions of the image files. it still doesn't work with the originals.

    thanks for all your support on trying to solve this,

    john


  • Beta Gold

    @dbini Your patch works out of the box for me. Changing the video image processing pref. doesn't change anything for me, but I'm running windows version.

    Maybe a bug report would be good. I have the feeling it should not react like this.

    Best

    Mehdi



  • changing the Video Image Processing pref to default also kills bonemap's frog, so its looking more like a bug, so to speak, rather than incompetent file management on my part.



  • Hi,

    I just wonder if there is a setting somewhere that is causing the issue? I know the option under File/YUV enabled or disabled can cause issues with image files. YUV should be disabled, I believe.

    It appears very unusual to me - I have never had that problem with photoshop files.

    What Isadora version are you working with? I can’t recreate your issue with transparency using .psd file.

    Cheers

    Bonemap