Lagging on edit mode scrolling and low frame rate with HD on High Sierra and isa 2.6.1

  • Hi dear all, 

    I'm preparing an interface for a Cine-concert, musician on stage, using a foot controller to increment movie player number, but that's not the point...

    It's a really simple patch to display original short movies in HD while they are playing.
    The mac is a MBP (13'' 2017 (14,1), 2,3Ghz (up to 3,6Ghz) Core i5, 8GB ram, Iris +Graphic 640 with 1536  mo) on High Sierra 10.13. ( computer is brand new, power nap in unactivated )
    Isa has just been installed (2.6.1 latest)
    The movies are in H.264 1920X1080 25ips 26,75mbit/s 
    Movie player is in performance mode, alpha straight, pb engine is AV.
    Isa preference default resolution is 1920X1080, in stage> preview is 1920X1080 ( cos i'll be using a syphon serveur to gather all proj before izzy map using) and display stage 1 is limiting to 16X9

    I tried building a new patch with just movie player and projector and my frame rate still goes below 10fps, 
    I need some help cos i just made them buy this new computer to smooth the video displaying, and i'm becoming anxious about the performance.

    Moreover scrolling in the edit mode is really slow and laggy and objects take a few second to appear and refresh...

    Thanks a lot for your advices

  • excluding a bug in Isadora, I would use pro ress 422LT for your videos, it is a bit less work for your machine that does not have a dedicated video card and is a bit low powered :(. Syphon can also use a bit of power, if you are working inside Isadora there is no need to use syphon, but maybe you have a need for this that is not clear in your post?

    The stage preview size can also be reduced, afaik there is no effect on Isadoras main processing with this setting and you will just use more of the limited resources available.

    I had some strange performance results a few versions back on OSX when there was no internet connection to the computer, this is probably not the case, but worth checking (try with internet on and off)

    Maybe you can post your patch and someone else can test the playback on another or similar machine.

  • @bennnid said:

    Moreover scrolling in the edit mode is really slow and laggy and objects take a few second to appear and refresh...


    These symptoms are similar to issues that can appear in Isadora when the Adobe Creative Cloud background application is running simultaneously.

    Check this advice from a couple of months ago.

    I hope it is a simple fix. 



  • Hi , and thanks for your support !

    @bonemap I don't have creative cloud, the os is brand new virgin and healthy ( for a Mac OS... )

    @Fred  ok I'll try reencoding files, I suppose I have to download this pro res 422 lt since I don't find it In mpeg stream clip, which video format would you use?

    QT, AVI, MPEG 4?

    thanks again mates !  

  • @bennnid said:

    pro res 422 lt

     oh and why not using 422 HQ since it's less compress, using less power to read, I don't think I have drive reading problems since I'm on a ssd soldered on the mother board... thanks for you lights


  • @bennnid you can go with HQ, but it is a much larger file and you will be pretty hard pressed to see and difference in quality unless you shot something on a pretty insane source.

  • @Fred thanks for the advice

    Although the lagging on scrolling edit mode is worrying me ... anyone else has this pb?

  • Tech Staff

    are there any OS updates available?.

    There was an issue with font rendering being changed by Apple causing a draw slowdown that could be scene in the scene editor as you mention. Mark made some changes to address it and I belive an new high sierra update also helped. 

    @mark am I remembering this correctly?

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.