assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

​Isadora freeze on startup (Windows 10)



  • Hi, not a user yet, but considering buying Isadora. My problem: it won't start up.

    I have a Windows 10 machine with a Sapphire R9 390 graphics card. On startup, Isadora freezes in the main project window, displaying "Cycles 999.9 FPS 99.9" in the bottom right corner. No buttons reacting, nothing i can do except close it from the task manager. Here is what I already did:

    - physically removed my second graphics card

    - updated my graphics driver to the latest version

    - verified Quicktime 7.7.9 is installed and its path added to system variables

    - uninstalled some possibly conflicting drivers.

    Nothing helped so far. There is no crash log in the Isadora crash folder, also no errors show up in the Windows event viewer. Isadora is present in my Task Manager with about 0.1% CPU and 1.0% GPU load, so it is actually doing something, I just don't know what and cannot interact with it.

    How can I find what the actual problem is and possibly fix it? I installed the same version on a Intel NUC with integrated graphics on Windows 10 and it runs just fine out of the box.


  • Tech Staff

    @arvog

    I just looked up your video card and don't see anything in the specs that would be a problem.

    It may be worth looking at your video card Control panel and checking if there is a section to allow switching the video card to the on board Intel graphics (done most often on laptops for power saving). Isadora needs to be setup to only use the dedicated card.

    Additionally deleting your preference file couldnt hurt. https://support.troikatronix.c...

    If you were setup in a crossfire config it might be helpful to 'undo' any settings that were made for that config since you have removed the second card. 

    Once isadora opens for you you may also want to look at the video preferences. There you can change a few settings to help optimize performance.



  • Thanks for the batch file @DusX! My onboard graphics are disabled in Bios, so only this card currently exists for the system. I never had a crossfire setup.

    I experimented a bit and found that the problem occurs as soon as there is more than one display device connected. I have a two monitor setup, so I did not notice this before. One monitor: starts fine. As soon as I connect a second monitor or projector, it freezes.

    It happens on both of my video cards, so I assume it is a problem of initiating the stages to the connected displays. If I set all stages to "none" in the preferences I can start up with 2 displays. If I then try to set stage 1 to the second display in Isadora I experience a regular crash. The crashdump references a lot of video related dlls and says that "the thread tried to read from or write to a virtual address without having the necessary access rights".



  • This happens to me all the time, unless i disconnect from internet. I do not know if it's my lousy internet, my (lousy?) wifi - dongle (tp-link TL-WN722N).

    It could be something related to update checking. I am not sure if it happens with 2.6. It happens all the time with 2.6.1.

    I am not using win 10 normally and in the middle of a project i do not bother to check better. I just switch the wifi off and everything works fine for long days of 16 hours. 

    h


  • Tech Staff

    please open a support ticket. The link is in my signature. It would be helpful if you can include you the crash report/s and system details. 

    Do you have access to any other video card types for testing?



  • I have the same problem, but it is intermittent.  This morning Izz opened and this afternoon it is freezing again.  No crash, just absolutely non-responsive.  For a while, Izz would open if I double-clicked on a particular file, but not with another, more recent file.  This afternoon Izz is non-responsive to that trick also.  This morning I had two different projectors (used at different times) plugged into my computer and Izz behaved quite well.  Have re-started my computer, disconnected from wi-fi, made a sandwich.  Then, for no reason that I can find, Izz will start up again with an innocent look and behave just fine.  Am using my Acer Nitro, Win 10 64bit, i7, NVidia GTX 1060.

    Valerie


  • Tech Staff

    @vjw It might help if you also open a support ticket.
    I will need to look for similarities between your cases, since I haven't experienced this on any of my test machines.



  • I don't know if my problem is connected to the others posted here, but maybe this helps: I tried different legacy versions of Isadora and I can start v2.0.5 without a freeze. All later versions do not work anymore. So the misbehaviour is likely due to a change that was made after v2.0.5. For me the freeze with more than one display device connected is consistent though when trying to run the current version, with and without internet connection.



  • Thanks.  I opened a support ticket.  Isadora opened when I clicked on Michel's position.trigger.izz in his reply to Kristen.  Then I could open my extant files without problem.  ??

    Internet connection or not doesn't make a difference for me.



  • I had run into a similar problem when I installed 2.6 on a brand new machine with Windows 10 (older machine was still on 7).  After many different suggestions, including going to 2.6.1, it was settings on the graphics card.  I made sure to optimize for performance and have had no problems starting since then. 



  • @dgaddyThanks - I'll give that a try.



  • Inspired by @dgaddy 's comment I had a look into my AMD graphics driver again and found a solution that works for me so far. 

    After an update of my Radeon driver from 18.3.1 to 18.3.3 one setting now solves the problem: Switching "Wait for Vertical Refresh" from the default "Off, Unless Application Specifies" to "Always Off". I think there must be a conflict in handling OpenGL.

    Thanks for everyone's input in this thread, I can now go on and actually test Isadora. :)



  • hello,

    i have the same problem on my new laptop when I launch Isadora with external monitor or videoprojector on windows10 with a gtx 1060 and an intel graphic card. (displaying "Cycles 999.9 FPS 99.9").

    best

    Pascal


  • Tech Staff

    @pascal

    Have you gone to your NVidia control panel, under 3d settings / manage 3d settings / program settings tab, and set Isadora.exe to only use the dedicated/high performance graphics card?
    This setting solves problems with Spout video sharing, and may be required on laptops that have NVidia optimus or the equivalent AMD power saving feature. 



  • @DusX .....Done and it seems to resolve the problem : Un grand merci à toi pour tes conseils et ta générosité.

    Best,

    Pascal



  • @pascal said:

    unch Isadora with external monitor or videoprojector on windows10 with a gtx 1060 and an intel graphic card. (displaying "Cycles 999.9 FPS 99.9").

     I am having the same problems, testing my Laptop Win10 + GTX960.

    If I start Isadorra with external monitor connected, it hangs with a white screen on both monitors.

    I've tried all possible solutions mentioned here, no luck.


  • Tech Staff

    @jaimun

    Please use the link in my or @DusX 's signature to file a support ticket.


    Best wishes,


    Woland


 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.