assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

[SOLVED] - Help: Isadora crash: error -4 on Hackintosh



  • Dears,

    Dears, Isadora crash on Hackintosh quad core lenovo y580 Yosemite 10.10.5. D'ont have the report at moment.


  • Tech Staff

    Error 4 seems to relate to an download error. https://discussions.apple.com/...

    Try changing your internet connection settings. (Isadora checks to see if an update is available if there is a connection)



  • @dusx

    Hello, thanks

    I made upgrade to El Captain and install new version 2.6 and works perfectly now (solved).

    Tested Isadora Syphon to madmapper and don't crash :) continuing...

    Cheers,



  • @fr4b3lo said:

    Tested Isadora Synphon to madmapper and don't crash :) continuing...

    Hackintosh!!! Man, some of you folks are super brave. ;-)

    When you have a second, I'd like to know how difficult it was to configure this machine - i.e., in terms of hours of your time. And do you have some kind of blazing fast graphics card in the machine?

    Best Wishes,
    Mark



  • @mark Hello Mark, sorry to reply this only now. I make a laptop Hackintosh on Lenovo Y580 to try. In el captain works pretty good, now busy on Sierra that has some bugs in video card. In laptops can't use Nvidia card (desktops yes) and this makes a bit disappointed.

    Now beginning again this error 4 and don't open Isadora, crash before that start Image where show Isadora version, load plugins, etc. Isadora worked pretty good in EL Captain. 


  • Tech Staff

    Hate to say it my friend, but we have no way to reproduce your issue since you're using a Hackintosh. You can submit a bug report using the link in my signature and send us a crash report or an error code if you've got one though. We'll see what we can do.

    Best wishes,

    Woland



  • This its very strange, Isadora its only app that don't load. I fix a lot of things in Sierra to make this Hack works properly.

    When I plug the same SSD in a old MAC open it and works, then I putt back again don't open. Also don't appears any the error in /log, only this message error -4. I think that its not a crash and for me the app stuck in some checking requisites like system ID, etc. What kind of specifications Isadora check on startup?



  • @mark said:

    Man, some of you folks are super brave

     So, in this Lenovo y580 was very easy and quickly in EL Captain. One day with this tutorial: https://www.tonymacx86.com/thr...

    But, I broke my keyboard connection in motherboard (has Backlight) and replaced it. I try Captain again and don't works, try Sierra and work with some glitches...two weeks for fix it and economize thousand euros :)


  • Tech Staff

    @fr4b3lo said:

    Also don't appears any the error in /log, only this message error -4. I think that its not a crash and for me the app stuck in some checking requisites like system ID, etc. What kind of specifications Isadora check on startup?

     Please make a support ticket using the link in my signature. If you can, please include a screenshot of your system specs and the error itself.

    Best wishes,

    Woland



  • OK. I opened a ticket . Today try open with comand line and get this: 

    MacBook-Pro-de-fr4b3lo:~ fr4b3lo$ open -b /Applications/Isadora/IsadoraCore.app/Contents/MacOS/IsadoraCore

    LSGetApplicationForInfo() failed with error -10814 while trying to determine the application with bundle identifier /Applications/Isadora/IsadoraCore.app/Contents/MacOS/IsadoraCore.


  • Tech Staff

    @fr4b3lo

    I responded to your ticket


  • Tech Staff

    @Fr4b3lo 

    Fr4b3lo managed to solve this thankfully.

    Just for other folks that might experience this in the future, could you explain how you solved this issue?

    You mentioned in your ticket that it happened .kexts were loaded or not trusted in extensions library.

    You also mentioned something about fixing the numbers of the UIID, Serial and others.

    Could you please elaborate?

    Best wishes,

    Woland



  • @woland

    Yes, its here (sorry for my english)

    First i run on terminal.

    sudo kextcache -i /

     And discover that all my hack kexts on S/L/E gave signature error.

    So,i took them and putt all in EFI Boot on Clover/kexts/Others and marked one option to force load this hackintosh kexts on Clover Boot. With this i erasing all non system kexts and disappear with the unsigned messages.

    I check my config.plist and edit correctly on Clover configurador some variables in SMBIOS generating the Serial Number and SmUUID that needs be the same on System Parameters Custom UUID.

    After that all works properlly including my Lenovo web camera, microfone, Open GL, etc and runs like a rock with 4 cores and Intel 4K.

    One important thing its: Only registrate Isadora after the system works very properlly (test a day) becose the generation of the new SmUUID makes new system serial and it needs match with the Isadora registration. I lost one of my remaning registration :( but...

    Very happy now!

    Many thanks to Woland,

    Best WIshes


  • Tech Staff

    @fr4b3lo said:

    I lost one of my remaining registration

     We'd be happy to reset that for you if you create a support ticket with our Sales/Orders department. :)