assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

[SOLVED] - Mapping shifts everyday when using iMac, Matrox Triplehead & 3 Projectors



  • Hi everybody, 

    I'm running a theatre show with some fairly simple projection mapping, yet everyday when I turn on the projectors, some or all of my saved mappings are either skewed or enlarged. This didn't happen for weeks during rehearsals, only once the show started, of course. I'm using a 2010 iMac running OSX Yosemite 10.10.5 and outputting to a Matrox TripleHead2Go. Sometime when I unplug and reconnect the Matrox connections (VGA to Display Port) it fixes the problem in one of the projectors. The other one I have to remap everyday now. Anyone have any thoughts or suggestions?

    Thank you!



  • @pbleopold Check you are getting the exact resolution on boot from your computer, also check that the projectors are sticking to their aspect ratio. Some time ago (and I am not exactly sure which version) I had trouble with small movements in the mapper not saving. I could solve this by having extra mapper surfaces that were not part of the projection (maybe projecting black, or completely out of the projection) and moving them a lot with the mouse - in my case sometimes nudging with the keyboard arrows were not saved. 


  • Tech Staff

    @pbleopold

    Many projectors crop black areas around the edge of the incoming video/picture. Make sure that if you start the projectors to send a white image. Or if they are already switched on send a whit image and hit the resync button many projectors have. I made the experience that in most of the time it was the projector because of the automatic crop.

    Best Michel


  • Tech Staff

    @michel said:

    Many projectors crop black areas around the edge of the incoming video/picture. Make sure that if you start the projectors to send a white image. Or if they are already switched on send a whit image and hit the resync button many projectors have. I made the experience that in most of the time it was the projector because of the automatic crop.

    @pbleopold 

    This is, in my experience, the issue in cases like this. Some projectors auto-crop, auto-keystone, and auto-correct the image in other ways upon startup. Michel's solution has worked for me in the past. 

    1. Boot up computer.
    2. Open Isadora
    3. Navigate to a preshow test Scene that is sending a plain white rectangle to UNMAPPED Projector actors at your desired resolution.
    4. Force Stage Preview to send the image(s) out to your projector(s)/beamer(s).
    5. Turn on your projector(s)/beamer(s). (The full white rectangle should prevent them from auto-adjusting.)
    6. Once you see the full white rectangles on the projectors, navigate to a preshow test Scene where you check your mapping.

    Doing things in this order has solved this issue for me in the past, though I did have one instance where I had to unplug and replug a projector every night in the past.

    Best wishes,

    Woland


  • Tech Staff

    @pbleopold 

    Did that solve your issue?



  • @woland yes thank you so much!!


  • Tech Staff

    @pbleopold

    No problem. About four years ago I spent three days going absolutely mad trying to figure this exact issue out. The forum pointed me in the right direction and now I include this step in all the shows I make.