• My DMX USB PRO Is only showing up under the "About my mac" section yet not in Isadora. whilst testing this on my macbook pro (OSX 10.11.6) it works just fine, but on my mac (OSX 10.12.6) i really need this resolved, any ideas would help. Thank you beforehand

  • Tech Staff


    Have you checked with the manufacturer if there are any software or firmware updates?

  • It shows up in the "pro manager app from" Enttec and it shows up in QLC+ It uses FTDI drivers and i have installed the newest on from fetidchip.com... Its only in Isadora i can't "see" it in the serial port setup...

  • Izzy Guru


    Just tried it on 10.12.6 with DMX USB Pro and Isadora 2.6.1 and it works for me:

  • @xlrstik 

    ftdi published two different drivers for there usb serial chipset

    VCP D2XX

    for Isadora your Operating System need to use the VCP Driver for the attached Device, only then it will show up in serial devices

    Apps like QLC+ con use both the more hardware specific D2XX and the general serial VCP driver

    to make it more complicated Apple started to publish there own AppleFTDI drivers a couple of years ago, but with limited functions

    to toggle between both ftdi drivers you can use the terminal or this tool


    more informations


    hope that helps


  • I fixed the problem -  I tried Qlab a it "hold me" that there were two files in my library that i should delete to make the DMX USB PRO interface work agin i did and it worked ... 

    It was this two...

     - D2xxHelper.kext

    - FTDIKext.kext 

    Thanks for the replys.