assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

[SOLVED] Windows dedicated GPU



  • Hi,

    After years and years on mac, I've finally jumped over the line and got myself a nice windows laptop...

    I have an integrated Intel GPU as well as a dedicated Nvidia 1070

    Long story short, even after setting the Nvidia as the default carte for Isadora in the display settings, it seems that it's only running on the integrated GPU (by monitoring the performances which goes up to 75% on the Intel GPU but stick to 0 on the Nvidia...). It's quite infuriating as I didn't get this setup to run Isadora on the wrong GPU

    I have other graphic apps which are running fine on the Nvidia as expected


    Anybody got some trick or idea?

    Thanks!



  • @maxime Do you have a system where you can disable the integrated intel GPU? EDIT- just saw it is a razer. How are you setting the GPU to use? The right click menu does not always work, right click and then chose change default  graphics processor and then select the application from inside the Nvidia settings that come up.



  • @fred I just went to the display settings of windows and put Isadora as "High Performance" which is linked to the Nvidia card.

    Should I go into the NVidia and Intel config panels after I right click to the desktop?

    EDIT: the nvidia is activated when i plugg an external display, but everything is on the intel if not... So what you're suggesting is to disable completely the intel? I would like to keep it for app which doesn't require so much power



  • @maxime I'm pretty sure you cannot disable the Intel with your laptop. And I think the way you are selecting the high performance mode is correct. Are you on the latest drivers? Are you using the nvidia driver for creators of the gaming version? 



  • @fred I guess I'm using the gaming driver which was installed by default... I should look for the creator driver then? (sorry didn't know such a distinction existed)



  • @maxime for other software I need the creators driver, but maybe @DusX has an idea. I cannot test right now, but I can check tonight if my settings stick for the use nvidia GPU option.



  • thanks a lot @fred ! I'll wait to see how it's working for you then before installing any new driver

    ( would that be this ? https://www.nvidia.fr/Download/driverResults.aspx/145417/fr )


  • Tech Staff

    I recommend setting Isadora to use the dedicated graphics card from the 3d setting section of the nvidia control panel.

    You have to do this for each version of Isadora that you install.

    It's easiest to install Isadora,  open it once and close it, then go to the 3d settings and add Isadora (it will appear in the list as a recent app since it was just opened)

    My current laptop has the same 1070 + integrated configuration. 



  • @dusx Thanks for the tip, it worked! (and fixed by bug of the alpha channel at the same time :) )


  • Tech Staff

    @maxime

    Good to hear the bug went away, however; Its still possible that your HapA files and the movie player are using different alpha types (the movie player doesnt know what format the video is using). 
    Changing the 'alpha mode' input of the movie player may help in the future. Also, in some cases you may need to convert the type (especially if its alpha straight, since many effects require pre-multiplication), so the FFGLpremultiply and FFGLunpremult actors can be very useful.
    generally you will see a 'halo' artifact around elements.. where the image fade to the background.
    This indicates some alpha mode formats are not optimal and should be adjusted.