assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Isadora Crashing on Startup



  • Computer Specs:

    • Windows 10 with the latest update
    • i9 9900k CPU
    • NVDIA RTX 2080 TI Graphics Card x2
    • Black Magic Quad 2 Card
    • 32gb RAM
    • 1TB Samsung Pro SSD
    • MSI Meg Godlike Motherboard

    I have the USB Key version of Isadora. We are trying to use 5 projectors, so in total, there are 6 displays. However, it has been crashing upon startup when more than one monitor is plugged in. I have tried taking out the Black Magic card out and updating everything, but nothing seems to work. We also removed the NV link bridge, but nada. Windows works fine on all displays and everything is fine with Watchout 6, Max, and Touch Designer. We've sent a report to customer service, but any other help or ideas are appreciated


  • Tech Staff

    @trnhnnh

    Please try to delete the preferences in Isadora, and look if this helps:

    https://support.troikatronix.c...

    Best Michel



  • Hello,

    Have you made a fresh install of Windows? I bought a MSI laptop last year and it crashed with any app using more than 1 screen (Isadora, TouchDesigner, Resolve, Unity). Killing all bloatware and not useful accessories it run perfectly well now.

    Hope that helps,

    Jacques



  • Michel & Jacques. This is a brand new tower that I personally built. The windows install is basically a fresh install. There is no bloatware since I built the tower and installed everything. If we only have 1 screen hooked up then isadora runs perfectly fine. Once we hook up a second screen Isadora will crash. I've gone through and removed the nv link bridge and the blackmagic decklink card. We have tried deleting the preference file, totally reinstalling isadora multiple times, and tried multiple older versions of isadora. Is there anyway that i can try the beta of version 3? Maybe the issue is magically fixed with version 3. I'm assuming this is a hardware incompatibility issue with isadora due to the system being so new.


  • Tech Staff

    @bruceaw

    I am not a windows user so I can't help you. But I guess @jhoepffner is talking about this: https://community.troikatronix...

    Best Michel


  • Tech Staff

    Please:

    • open Isadora with 1 display.
    • then open Isadora preferences, on the Video tab, uncheck 'Shared OpenGL Resources'
    • click OK and close Isadora.
    • Re-Connect your second Display and re-open Isadora.

    I suspect this will allow it to work for you.

    The hint was the nv link bridge, this points out that you have multiple video cards, which often causes a conflict with the Shared OpenGL Resources feature.
    Turning this feature off causes a OpenGL context to exist separately on each video card, therefore; video targeting a stage connected to 1 card can't be mixed with video targeting a stage connected to another card. This becomes clear in the patch, as you will have to define the stage target at the beginning of a chain, rather than at the Projector actor (eg: Movie Players will have to set the stage target), and you can't mix differently targeted video via, for example, the Video Mixer actor.

    Isadora 3 has removed this preference setting, and in-fact defaults to it being 'checked'.
    However, due to some core changes to how Isadora 3 works, I have been able to use Isadora 3 with a custom system with (not recommended) 3 video cards installed.

    Files created in Isadora 2 not using the Shared OpenGl Resources feature, will open in Isadora 3, however, the Stage inputs are made N/A and stages are once again set at the Output (eg: Projector). Some work to set the outputs to the correct stage number will be required to fully update the files.

    Multiple video cards is NOT optimal.
    Isadora3 will create a shared OpenGL context on the Primary card (which ever isadora.exe is set to use). Video output via the other cards ports/connections need to copy this data from the primary card. This process is not as fast as running on a single card.

    Troikatronix does not recommend multiple video card configurations, and we do not officially offer support for such setups.

    Performance will be better with a single high-end graphics card, and professional multi-output hardware connected, such as a DataPath.



  • @dusx

    I removed the black magic quad 2 card and removed the second gfx card, then set the settings as you suggested and once I connected a second monitor the exact same problem happened again. Any other suggestions?



  • I had a simular problem. With a lot of help from Ryan Webber, and a bit of Google-ing I found a solution for Isadora not starting on my MSI. The (on board) Intel CPU was listed as GPU 1 and that's where my Radeon supposed to communicate with. This probably happened by an auto update from Intel. I've managed to switch Intel to GPU 0 and all is working well again. 


  • Tech Staff

    @bruceaw

    The suggested issue JHT posted is a possibility, especially since you have been made numerous modifications to the setup.
    Following the steps I provided will get things up and running most of the time, so it is very likely that you have some non-standard setup elements.

    What is your support ticekt number?
    I will followup with you in greater detail there.



  • @dusx

    We gave up on Isadora for now. The installation opens tomorrow so we switched over to resolume. I'm off work until Wednesday. Once this and my other event close out I'll do a small test setup in my office to hopefully get Isadora working. Once I have it setup in my office I'll try completely disabling the audio hardware.