assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

[SOLVED] Long usb cable latency



  • @fred thats a very good idea !!! Thanks



  • Dear @fred   

    apparently that was the problem. Also the video looks much more fluid now. Anyway I will leave it running for a long time to rule out any other problems. continued to be concerned with the issues of light and power cables.


    It would be interesting to refresh the whole community of the relationships that occur between the different video sources and their respective resolutions, and the best or most appropriate practices when combining video and live capture.

    Thank you very much !!

    Best,



  • @ril in general it is much better to run devices at their native resolution. There are tools inside Isadora that can do efficient scaling. This applies to input as well as output, in general running a camera capture, or a projector at a higher resolution than native does not do anything but use extra resources, and upscaling does not really help. Using GPU based scaling, such as in the mapper is a great way to change the size of an image.

    Isadora is also natively resolution agnostic, as positions and sizes are percentage based changing resolution of cameras and video projectors (as long as the aspect ratio is the same) won't change your composition.

    Definitely with USB cameras that stream the image with h264 upscaling or downscaling via the CPU on capture is an expensive process and also does not do anything for the image.

    With cameras that are on auto settings like USB cameras low light will make the camera go to long exposure that can give extra latency.



  • Thank you @Fred for all the insights !

    @fred said:

    With cameras that are on auto settings like USB cameras low light will make the camera go to long exposure that can give extra latency.

     This is what I think also happended to me because in my project there is so much dark during many times. But when the light conditions get better the latency continues, so had to stop the live capture and start it again. Thats the only solution I have found to restore it. Am I correct?

    Best,



  • @ril if you were running the camera at 1920*1080 no. The lag in low light goes away as soon as there is light.

    Logitech make a control app that lets you fix some of the camera settings manually that may work for you too.



  • @fred yes I would love that app !! Is it for Mac ? Find it on the web page?

    Thanks !!

    Best,



  • @ril yes, the page for the camera on the Logitech site



  • @fred     Looking in. to it... but cant find the one you talked about. https://www.logitech.com/en-us

    Thank you. Best,





  • @administrators fred Thank you !! already install and working. 

    again check that opening the safari I immediately get latency. But in reharsel situation with wifi off latency appeared. Then will be the low light condition what is bothering?