assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

help connecting to Advatek PixLite controller



  • Hi all during this crazy global yet local time, i was lucky to receive a new Advatek PixLite 16 Long Range Mk2 controller with WS2812B pixel strip (2.5m 60pixels/m) the day before NZ went into 4 weeks lockdown. I've managed to get it working with MadMapper but no luck so far with Isadora (running 3.0.7 on OSX 10.12.6) so thought i'd reach-out to you good folks in the hope you can help.

    I've read the various forum posts, including the very comprehensive https://support.troikatronix.com/support/solutions/articles/13000042899-controlling-led-strips-via-artnet and https://community.troikatronix.com/topic/6520/matrix-color-send-in-v3, and tried playing with various plugins including Artnet 64bit https://troikatronix.com/plugin/artnet/ and DMX Universe - Enttec compatible https://troikatronix.com/plugin/dx-dmx-universe-enttec-compatible/

    ArtNet Send actor has intf addr set to 192.168.178.25 which seems to be the "local IP address" according to the bottom of the Isadora preferences window. My Mac's IP address is set to 192.168.0.10 and the PixLite controller's is 192.168.0.50 (both with subnet mask 255.255.255.0)???

    And i've configured the PixLite controller using Advatek Assistant "Advanced Output Configuration" as follows

    Is there a simple way i can check Isadora is connected to the PixLite controller?

    Any help much appreciated, take care, stay safe and stay home, Mr J


  • Tech Staff



  • Set all your IP's and subnets to the same pattern. 192.168.178.25 is not in the right family. sAcn can work over different IP ranges,madmapper is using sAcn, maybe thats why its working. Artnet is very specific.

    Your local address and your macs address is the same thing, so that does not make sense at all, and its possibly what causes your problem



  • @fubbi I have the pixlite controller connected directly via a lan cable to my MBP using a thunderbolt-to-ethernet adaptor, who's ip address is 192.168.0.10 whilst 192.168.178.25 is the ip address of my wifi

    Previously i tried changing the ArtNet Send actors output intf addr from 192.168.178.25 to 192.168.0.10 with no luck but have just changed the input intf addr from nothing to 192.168.0.10 and is now working, so thank you

    does izzy support sACN?

    rgds, a happy Mr J


  • Beta Platinum

    @mr_j said:

    r connected directly via a lan cable to my MBP using a thunderbolt-to-ethernet adaptor, who's ip address is 192.168.0.10 whilst 192.168.178.25 is the ip address of my wifi

     Hi,

    Good to hear you have got it working.

    Have you tried connecting the device to the wireless router?

    I have setup LeDMX4 PRO For strips and that included a lan cable from the board to a wireless router. I was then able to pick up the device using the ip address provided to the board by the router. It appears to me, as Fubbi suggests, you would need to get all of your devices on the same network ip area, so that only the last number of the address octet is different. As your computer is using your wireless network you can try hooking up the device to the wireless network by attaching the lan cable between the device and the wireless router. You might consider using a dedicated network router for these kind of projects, if that is practicable.

    Best wishes 

    Russell 


  • Beta Platinum

    @mr_j

    Izzy doesn't support sACN, it only support ArtNet at the moment (Limited to 4 universes per node)



  • @mr_j got it. 

    still, when troubleshooting is a good idea to turn off wifi. Habits from back in the day, lanbox for example hated wifi being on.


  • Beta Platinum

    @fubbi said:

    back in the day, lanbox

     It would be great to see a modern equivalent of the Lanbox.

    Kind Regards

    Russell