assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Wearable Inertial motion sensors


  • Tech Staff

    @eight

    With the new update from NI Mate you are able to record oni files. I tried to drag an oni file into the coco kinect window, but its not showing up. Any ideas? 
    Alex


  • @feinsinn:

    Please share the oni file, I'll check.
    --8

  • Tech Staff

    @eight

    Cool, thank you. Link to the file: https://www.dropbox.com/s/vne34217gkvrjq6/NI_mate_2013-12-17_08-26-18.oni.zip


  • @feinsinn I am traveling right now: tried to download it but it takes too long in a cafe I sit. I will try again, once I have a good connection.

    --8

  • Tech Staff

    @eight thank you for your engagement! All the best, Alex



  • @feinsinn: Sorry it took me this long. I am finally home and was able to check your file –– dragged it on the CocoKinect app and it worked! OSX 10.9.1, MBPr.

    Just in case I attach the executable.
    Best regards,
    --8

    b2f06e-screen-shot-2014-01-04-at-1.15.30-pm.png efe5b8-cocokinect.app.zip


  • Tech Staff

    @eight interesting, I downloaded the app and now its crashing not able to open it like before:

     Dyld Error Message:
      Library not loaded: ../../../Bin/x64-Release/libnimCodecs.dylib
      Referenced from: /Users/USER/Downloads/CocoKinect.app/Contents/MacOS/CocoKinect
      Reason: image not found
    any ideas?


  • These libraries are shipped with the executable and referenced by the executable: eight:MacOS eight$ otool -L CocoKinect CocoKinect: /System/Library/Frameworks/Accelerate.framework/Versions/A/Accelerate (compatibility version 1.0.0, current version 4.0.0) /System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox (compatibility version 1.0.0, current version 492.0.0) /System/Library/Frameworks/AudioUnit.framework/Versions/A/AudioUnit (compatibility version 1.0.0, current version 1.0.0) /System/Library/Frameworks/CoreAudio.framework/Versions/A/CoreAudio (compatibility version 1.0.0, current version 1.0.0) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationServices (compatibility version 1.0.0, current version 48.0.0) /System/Library/Frameworks/QuickTime.framework/Versions/A/QuickTime (compatibility version 1.0.0, current version 2826.0.1) /System/Library/Frameworks/QTKit.framework/Versions/A/QTKit (compatibility version 1.0.0, current version 1.0.0) /System/Library/Frameworks/CoreVideo.framework/Versions/A/CoreVideo (compatibility version 1.2.0, current version 1.8.0) /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon (compatibility version 2.0.0, current version 157.0.0) /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL (compatibility version 1.0.0, current version 1.0.0) /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa (compatibility version 1.0.0, current version 20.0.0) /System/Library/Frameworks/CoreData.framework/Versions/A/CoreData (compatibility version 1.0.0, current version 481.0.0) /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation (compatibility version 300.0.0, current version 1056.0.0) /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit (compatibility version 45.0.0, current version 1265.0.0) @executable_path//libnimCodecs.dylib (compatibility version 0.0.0, current version 0.0.0) @executable_path//libnimMockNodes.dylib (compatibility version 0.0.0, current version 0.0.0) @executable_path//libnimRecorder.dylib (compatibility version 0.0.0, current version 0.0.0) @executable_path//libOpenNI.dylib (compatibility version 0.0.0, current version 0.0.0) @executable_path//libusb-1.0.0.dylib (compatibility version 2.0.0, current version 2.0.0) /usr/lib/libobjc.A.dylib (compatibility version 1.0.0, current version 228.0.0) /usr/lib/libc++.1.dylib (compatibility version 1.0.0, current version 120.0.0) /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1197.1.1) /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation (compatibility version 150.0.0, current version 855.11.0) /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices (compatibility version 1.0.0, current version 59.0.0) eight:MacOS eight$ however, it seems in your environment they are being searched elsewhere (../../../Bin/x64-Release/...). This may suggest that you have a DYLD_LIBRARY_PATH set. On my machine it is not set, this is suggested by a homebrew I use to manage most of my dependencies. At this point I would suggest to unset DYLD_LIBRARY_PATH env variable, or copy the dylib files into location your system expects (../../../Bin/x64-Release/) to debug this. --8 03e38f-screen-shot-2014-01-04-at-2.02.53-pm.png



  • Hi all,

    I just bought another kinect, model 1473, and it does not work with this app. Looking at this [thread](http://forum.openframeworks.cc/t/ofxkinect-issue-with-kinect-model-1473/11632), I think the issue is the change in the API, which occurred since original model 1414 (the kinect that I have, which works with this app). 
    In other words, CocoKinect will only work with kinect 1414.
    --8


  • .... that might explain why i couldn't get it to work....