[SOLVED] Geforce GTX 1080 Ti not working with ISADORA on Mac Pro 2012

  • I just installed an EVGA Geforce GTX 1080 Ti  in my mac Pro 2012 12 core 3.46 Xeon.. and Isadora wont even open now. I just decided to upgrade from my stock radeon 5770. I have isadora 3.0.7 and 2.6.2 and neither version will open now... just crash every time I attempt to launch. I installed the proper drivers for my Mac OS 10.13.6: Nvidia web driver 387. and cuda driver 418.163 which are compatible with my system. Curious if anyone else has any experience with the GTX that might be able to shed some light. I researched it and seemed like people were saying on this forum that they had success with this card. I just put my 5770 back but left the Nvidia drivers installed and isadora works. 

  • @demetri79

    Hello Demetri, I've done pretty much the same configuration twice (MacPro 2012, 1080 Ti, same Xeon), without any issues. As I don't have these Macs available at the Moment, I can't tell which drivers version they use. But they are some older for sure. Maybe try an older version of the Web Drivers.


  • I tired to install the some of the previous versions of the web driver and it wouldnt let me... came up with error message saying my os is not compatible.. i have the correct version installed so i dont understand why my card work with my other apps just not isadora.. final cut, abelton, pro tools, everything else i use is working. how could this application not open based on what video card is installed? and it is working for other people what gives? I just can't catch a break and get anything working. Any tech staff here have any insight here? This is a massive problem for me. thanks guys

  • @demetri79

    You need to choose the version for the exact build number. It must be 10.13.6 and not just 10.13. or High Sierra. Try this list:


  • Tech Staff


    If it is currently causing that many issues for you, please get in touch with Izzy technical support by creating a support request here https://support.troikatronix.c...

  • @dillthekraut

    thanks for the help but yes i made sure and used the right version for my build.. it actually wont even let me test out any of the other versions.. it looks at the build number on install and prevents any previous versions. It does seem like a driver problem though because im getting ghosting and tracing on finder windows as i drag them around the display. and now upon further trouble shooting my other apps the display video like pro tools are displaying  choppy video.

  • @demetri79

    I always had some little ghosting, but it never was really a big issue in terms of working with it.

    Did you try cleanly uninstalling the drivers, before installing other versions?


  • So I solved the issue.. cant figure out how to update the thead to say solved like the others do.

    So i stumbled onto the solution on accident. I was trying to install a fresh copy of 10.13 on a new drive but the installer would not let proceed and came up with a message saying I must update firmware first to use the installer.. so I felt it was risk but i was desperate and in the depths of hell so I gave it a shot. i checked the fresh install drive with the new GPU and it worked instantly.. so i thought it was my origional OS had some corruption.. but then i booted back to the old OS drive and right away everything worked fine.. isadora worked again and the ghosting on finder windows was gone.. so I'm guess it was the firmware update that fixed the issue since i made no changes the original drive or sofware.. not even sure what firmware was updated.. oh well.. that sure sucked for a fed days. I had no indication anywhere that there was firmware out of date. thanks for all the help everyone. Cheers

  • @demetri79 said:

    cant figure out how to update the thead to say solved like the others do.

    Glad you solved it! Don't worry about adding the 'SOLVED' to the header. We do that for you so that everyone knows there's a solution.

    Best Wishes,