assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

[ANSWERED] Is Isadora 2 compatible with macOS 10.15.x Catalina?



  • I know this is not a new ticket item, but it is an item I need to resolve and understand.  
    Mac OS 10.15.6 and I just downloaded V3 of Isadora.  Says it is not updated yet for this computer. 
    I saw something about it, but it is no longer something I can find. Any help would be lovely.  Thanks



  • @jayahld said:

    Mac OS 10.15.6 and I just downloaded V3 of Isadora.  Says it is not updated yet for this computer. 

    Really? Can you give us a snapshot of the exact dialog you you saw?

    Isadora v3.0.7 is totally Catalina ready. I'm not sure what this means.

    I have Catalina v10.15.5. I will go update right now to check this.

    Best Wishes,
    Mark



  • @jayahld

    I just installed the latest Catalina (10.15.6) and reinstalled Isadora. I received no such warning.

    Searching on Google for Catalina and the error you mentioned (updated yet for this computer) does not return any meaningful results. To help you further, I need to know exactly what that dialog said.

    But suffice to say, hundreds of users are using Isadora on Catalina and it works fine.

    Best Wishes,
    Mark



  • @mark 

    kHere is the image file.  Also know that I do not have the key with me as it is in my office.  



  • @jayahld said:

    Here is the image file. 

    Even though you say you are running Isadora v3, this error. would indicate otherwise.

    Instead, it seems that you are attempting to run Isadora v2 on Catalina, which is not possible because it is a Isadora v2 is 32 bit app and Catalina will only run 64 bit apps. (macOS Mojave and older ran both 32 and 64 bit apps.)

    This error is described on this page from Apple where it says "When you attempt to open a 32-bit app, you will see an alert that the app needs to be updated to work with this version of macOS, or that the app is not optimized for your Mac and needs to be updated." It shows the same dialog you attached above.

    You must upgrade to Isadora v3 if you want to run Isadora under Catalina. You can download the latest version of Isadora 3 from our "get it" page.

    Best Wishes,
    Mark