assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

NDI output of camera stream only visible if something's behind it



  • Hi! Weird problem with a simple practical solution, but thought I'd post here in case anyone had any insight...

    I was streaming in video from a DSLR over an ATEM Mini HDMI switcher. With Video In Watcher / Projector, I can see the video stream on the stage nice and clear (windowed, through Forced Stage Output) - so far so good.

    However, when I streamed this output over NDI to a second computer the screen was completely black. Fiddled around, couldn't see what was wrong, thought I'd have to go back to using a webcam... then realised that I could see the video as long as there was something behind it.

    The quick fix was to put a solid black shape at the back of every scene with the DSLR video - suddenly I could see everything on the NDI stream, just like it was on the 'Stage 1' window. If I shrank the shape down, it had the effect of cropping the DSLR video.

    So the problem was easily fixed practically, but I'm wondering what may have been the cause of this, and may it affect anything else which I should be on the look out for? Specifically, NDI-streamed video appearing differently to what's on the Stage window

    Thanks! -- Django


  • Beta Platinum

    @django

    Hi,

    That sounds unusual. And as if there is some kind of blend mode causing the issue. I did have a black video through NDI yesterday when streaming to Blackboard, but after resetting and restarting Isadora the video stream resolved. Perhaps post a screen capture of the patch so we can see the settings.


    best wishes 

    Russell



  • Will take another look later when I'm back at my machine -- I also found that the contrast adjust actor would make the video completely black, maybe it's a related issue.

    Dj


  • Tech Staff

    This sounds like an Alpha channel read/write issue.
    I would like to know the Isadora version being used.. and what software was picking up the NDI feed?
    Perhaps I can track down the cause.



  • @django said:

    I was streaming in video from a DSLR over an ATEM Mini HDMI switcher. With Video In Watcher / Projector

    Does this mixer allow you to get video into the Live Capture Settings using the Blackmagic driver? Or????

    I see on Blackmagic's website it says "ll ATEM Mini models have USB that works like a webcam so you can use any streaming software" -- so perhaps that's how the video is getting into the system?

    Best Wishes,
    Mark



  • Sorry for delay -- back now. Recreated the problem in a simpler patch...

    @bonemap said:

    That sounds unusual. And as if there is some kind of blend mode causing the issue. I did have a black video through NDI yesterday when streaming to Blackboard, but after resetting and restarting Isadora the video stream resolved. Perhaps post a screen capture of the patch so we can see the settings.

     Have reset preferences and restarted Izzy and still found the bug. Have fiddled around a little with blend modes -- although anything non-black should be visible in any mode surely?

    @dusx said:

    This sounds like an Alpha channel read/write issue. I would like to know the Isadora version being used.. and what software was picking up the NDI feed? Perhaps I can track down the cause.

    Isadora 3.0.7 -- and NDI Studio Monitor / NDI Virtual Input. Just tested with NDI Studio Monitor on the same computer and the problem persisted.

    @mark said:

    Does this mixer allow you to get video into the Live Capture Settings using the Blackmagic driver? Or????

     Probably? I've been using it with the Windows driver so far though, since the switcher can do the webcam-style input you described. Maybe thats my problem.


    Screenshots of tests -- in the first one everything is working under native resolution. Then I knock the res down to half-size, and it will only appear over something else. Notably, what appears in Izzy is different to what is outputted over NDI.

    And then ran a test with the contrast adjust actor -- just realised I have each stream on a different blend mode, but all the same... This time, even in Izzy we can't see a thing.

    (Contrast adjust has its default values, so should be outputting the exact same image)

    Am yet to download and try the Blackmagic driver option -- though from my end I'm probably happier just putting black boxes in the background for now.

    Best,

    Django



  • @mark

    I can confirm. I have just connected my BM ATEM Mini to my computer via USB It appears in the Input/Live capture menu like any webcam under Apple driver.

    Video is OK also with actors "Contrast  adjust" and "Text draw" between "video in watcher" and "Projector"

    best

    Jean-François 



  • @mark said:

    Does this mixer allow you to get video into the Live Capture Settings using the Blackmagic driver? Or????

    And in Windows it's the same: the ATEM input is seen as a Webcam in Isadora, and you just set the driver to Windows NOT Blackmagic.