[ANSWERED] Start Syphon recording from inside a stage?

  • @jfg

    cool. thanks v much

  • @jfg

    Yay! it works! 

    merci de votre assistance. je suis très heureux!



  • @jfg

    Hi Jean-Francois, can i ask a bit more about this?

    I've recreated your User Actor, I'm not quite sure how it works. I'm able to start & stop Syphon recording with "Option+Command+ 'r' ' keyboard commands now (which is great) , but I'm not able to automate the start-stop from within the stage and to assign it to other actors etc.


  • @Notdoc

    I am not sure to understand where your problem is…

    if you activate the trigger for record, the record will start. You can use the same trigger to activate something else like a trigger value actor or a player.



  • @jfg


     Is that 'Syphon Recorder 2' Actor your own User Actor? 

    I have Syphon Receiver' and 'Syphon Stage Output' Actors, but not a 'Syphon Recorder'.

    I re-created the version you showed previously, but the trigger failed to activate Syphon recording...

    I feel sure I'm missing something really obvious...

  • @Notdoc

    Yes, it is the user actor I show in my first answer.

    It could have two causes:

    - Syphon Recorder must run

    - you need to activate "Syphon" in Menu Output/Stage setup



  • @jfg

    thanks, sorry my mistake I didn't understand your second image. Now I do... 

    But i'm still not having success. Syphon is activated in the Stage prefs, and the 'option+command+'r' keystrokes start recording no problem... but the User Actor I am copying from your example is not working for me. Here it is, maybe I am missing something? 

    TBH I don't really understand how the actor is supposed to work, as manually flipping the 'Trigger Event' from 'Off' to 'On' doesn't begin recording either. But the keystrokes do. I'm baffled.

  • @Notdoc

     If Syphon Recorder is open and syphon activated in the Stage Setup, the 'option+command+'r' keystrokes works anyway also without any actor.

    If the manually flipping the trigger Event doesn't work, you haven't correctly installed the QC KeyeventEmulator or there is a problem with authorization in Catalina. or the  QC KeyEventEmulator is 32bit.

    I use still Mojave on both computer and have no Idea about Catalina.



  • @notdoc

    QC keyeventemulatoI nstallation

    There are two different files to download:

    13d8d0-keyeventemulator.zip 38f248-keyeventemulator.plugin.zip

    move the KeyEventEmulator to this place :

    and  the KeyEventEmulator.plugin to this place:
    /Library/Graphics/Quartz Composer Plug-Ins/

  • @jfg

    ok, so this is not a Syphon problem, it's about getting the Key Event Emulator working. I didn't understand that until now. But I have installed it as you describe...if i understand correctly, this should be here:

    and this here:

    and if this Actor looks like this..:

    ...then Syphon Recorder should be recording, and when it's like this..:

    ...it should stop..?

    Currently that isn't happening for me, although the Syphon Recorder is otherwise working fine, switched on, responds to manual keystrokes etc. 

  • @notdoc said:

    and if this Actor looks like this..: ...then Syphon Recorder should be recording, and when it's like this..: ...it should stop..?

     Not really. You have to switch the "trigger Event" input to on then to off like you can see in my user actor:

    Trigger value 1 > Trigger delay > trigger value 0

    It is a strange behavior of the QC KeyEventEmulator actor, I think it is because it simulate a keyevent. We except a trigger or as you discribe on for record and off for stop. But if you look on the Syphon Recorder you use also the same keystroke for record and stop record. Here it is the same: Record= on then off, stop record=on then off both in a short time (0,1 s)

    Perhaps it is better to understand with this construction:



  • @jfg

    Thanks, I really appreciate the effort you are making with this. 

    Unfortunately it is still not working, even after I re-created the nice simple set-up you have shown with the Wave Generator, and the 10Hz square wave. I can see it flipping the on/off but Syphon is not triggered.

     Maybe it's a Catalina problem. It's frustrating, as I really need to trigger Syphon recording with more precision than the keystrokes permit, as it will save endless fiddling about in Premiere afterwards.

  • @notdoc


    You can try this app http://charlie-roberts.com/mid...  that converts midi events into keystrokes. It works in Catalina and triggers the recording in Syphon Recorder.
    I hope it helps you.

  • @jandraka

    thanks, that will be a useful workaround. Very helpful.

    But I would still be curious to know if any Catalina users are able to use the QC KeyEventEmulator...