Spout Receiver with Unreal Engine: Cannot create DirectX/OpenGL interop


  • I am running Windows 10 on bootcamped MacbookPro 16 (late 2019), and am getting a "Cannot create DirectX/OpenGL interop" message from Isadora 3.0.7 while trying to get a texture in the Spout Receiver from Unreal Engine.

    I have eGPU with NVIDIA 1080 Ti and the Spout Settings' Diagnostics on this setup show:

    Spout Demo Program
    DirectX 9c installed
    DirectX 9 device available
    DirectX 11 device available
    Primary adapter : ATI Technologies Inc.
    NVIDIA GeForce GTX 1080 Ti (Display) : 
    Microsoft Basic Render Driver (Secondary)
    Desktop system detected
    NV_DX_interop extensions available
    OpenGL/DX11 texture sharing succeeded
    Compatibility - Texture (DirectX 11)

    Demo Spout Sender/Receiver work fine.

    Any pointers to a fix would be appreciated.

    Thanks!

  • Beta Platinum

    I dont believe that Isadora works with eGPU, so personally I think that Izzy is actually talking to your intergated graphics, while your other programs are talking to the eGPU.

    But this is something that the Technical staff can tell you more about / perhaps @mark can chime in and shine his light on it.

  • Tech Staff

    You need to be certain that both Unreal and Isadora are using the same GPU.
    You can set which GPU an application uses in the video card control panel. ( I am most familiar with nVidias, where it is foudn under 3D settings)

    This article explains

    Once both the EXE for Isadora and for UnReal are using the same GPU it may work (your setup is untested, so I am not positive).
    Hopefully that's all that is needed.


  • @DusX Thanks for your help.

    1) on my setup the "Select the preferred graphics processor for this program" option is missing:

    2) there is alternative way to set the preferred card for a program, https://www.howtogeek.com/3515... , which I followed :

    However, Task Manager still reports that Isadora is using gpu 0 (built-in) rather than gpu 1 (nvidia), even after restart:

    Unreal Engine is rightfully using GPU 1.

    Thanks!

  • Tech Staff

    @eight

    Try to reboot, and then navigate to the Isadora folder, find Isadora.exe and right click on it.
    Select "Run with graphics processor" and then select "High Performance..."
    Hopefully you have this option, and it allows you to open Isadora using your NVIDIA gpu.