Thoughts on XLR8 Proview USB video capture?

  • There are some new devices that do mac native video capture. I have not tested these but they look rather affordable. The question is if these allow to get live video stream into Isadora for 25USD
    • 640 x 480, 29.97 frames per second NTSC video capture

    • 640 x 480, 25 frames per second PAL/SECAM video capture

    • High contrast, high quality video -better than DV at the same size

    • Excellent audio/video synchronization

    • Uncompressed YUV format: 66.5 GB per hour for video and audio

    • Compressed JPEG format: 3 GB per hour for video and audio

    • 640 x 480 single frame capture

    • Audio support up to 48 KHz 16-bit stereo for devices that have audio input

    • Auto-Detect Input And Format, to automatically adapt to the current video source

    • Easy to use, AppleScript enabled capture software with fast full screen playback

    • Software to export movies to any QuickTime supported format, including DV and H.264

    • Push to start push to stop Video Capture button

    • Handheld design to let you seat in front of the TV

  • Thanks vanakaru for the further information!

    I've since purchased an Easy Cap DC60+ (v.3) from the eBay site you recommended. I downloaded the Video Glide drivers and purchased a SN from EchoFX.
    I've had issues getting it to work, and if you have any advice that would be great. 
    Here's the situation - connected camcorder to the Easy Cap via the composite video feed, connected Easy Cap to my Macbook Pro (running Lion), and then started my licensed version of Video Glide Capture software. The 'Video Glide' window showed green, so I went to RECORD>Video Settings. I selected the composite feed from the Video Glide device, and for a few seconds, I saw the feed coming from my camera. Then it went back to green, and then to black.
    I've tried other input devices (i.e. DVD player), and exact same reaction.
    I then closed Video Glide, and opened latest version of Isadora. Went to INPUT>Live Capture Settings, confirmed the device was set to VideoGlide:Composite, and hit "Start live capture". The preview screen goes green, then black. Going into the 'Settings' of that device, I again selected 'Composite' in the drop down menu, and same deal as I saw when in the actual VideoGlide software - saw my camera footage for a second, then preview went green, then black.
    Any experience with something similar? Could my cabling be to blame, or perhaps the camera itself?
    I was worried the Easy Cap might be an older version, so I checked in System Profiler - the device specs match those of v.3 you have listed above. The CD that came with the Easy Cap is white, black and yellow - not purple, as you say above, which worries me. However, cause I'm on Mac, haven't touched that CD. 
    Any help is appreciated!

  • So I found a moment to test this today. It runs as good as before. Both s-video and Composite. However I am still on SnowLeo and probably will skip Lion entirely.

    At my next spare moment I will try with Lion.
    Where are you located. If in EU I can send my EasyCap for you test.

  • Unfortunately I'm in Australia, but thanks for the offer!

    Fortunately, I have access to a Mac Pro that's still running Snow Leopard. I'll test the EasyCap on that OS tomorrow, and fingers crossed that'll solve the issue! If not, the device itself might be a dud, in which case I'll get a replacement from the eBay seller. 

  • The final chapter in this issue - 

    I tested the EasyCap on Snow Leopard, and experienced the same error. I requested a replacement device from the eBay seller. The replacement device did the exact same thing - saw the video feed for a few seconds in VideoGlide, & then the preview screen went green, then black.
    Giving up on the EasyCap DC60+, I went back to the list of devices that EchoFX recommend to accompany their VideoGlide driver ( If I'd paid more attention to that list, I would have seen the device recommended for Australian customers - the Kaiser Baas DVD Maker (
    It's a little deceptive because of the name - you wouldn't find it if you Google'd "Video to USB device" - but this device is exactly what an Isadora user needs to stream video via USB. It comes with the VideoGlide program on CD, with a SN. Compatible with Isadora 1.3.0f24, and Mac OS X Lion (if I have a chance, I'll check it's compatibility with SnowLeo). 
    As the SN alone costs US $30 from EchoFX, the Kaiser Baas device is ridiculously cheap. It is fantastic quality, and has a one year warranty. You can purchase from the website, but - most importantly - it's readily available from Officeworks and Dick Smith Electronics - very common stores in Aus.
    So in the end, I was able to drive to a store 5mins from my house, and purchase the exact product I needed - for under AU $70.
    Thank you all for your advice!

  • I am very sad about my advise that produced so much trouble. Sorry about that!

    But at least this resulted a stable solution and valuable information to others.

  • Please don't apologize! I think I just experienced some bad luck with the EasyCap - others, inc. yourself obviously, speak very highly of it! And yes - I can happily say I now know the answer to that scenario.

  • Tech Staff

    Glad you got it sorted. I've still tested my easy cap but it was problematic for me a while back. Need to test it properly again for my own sanity!

  • I'm not having any luck with v.3 of the EasyCap running 10.6.8

    System profiler sees something (similar profile to vanakaru's above with different vendor) but nothing doing in QT or Isadora.
    Have Ben's QT component installed.
    Anybody else have suggestions?
    MBP 2.8GHz Core 2 Duo 

  • Unfortunately I never had any luck with the EasyCap device, and as the above post describes, gave up and moved onto another device. I found the one that worked for me (Kaiser Baas DVD Maker) off the EchoFX recommended list ( Maybe others have had better luck with it! Hope that helps.