[SOLVED] OpenNI Tracker: Windows DLL Load Error (Error = 0000007E)


  • https://community.troikatronix...Hi,


    I am using Kinect 1, have the proper SDK (1.8) and tried using it with the provided dev tools and it works. 

    I wanted to use OpenNI tracker plugin, but am encountering an error. There is a post about it from a few days ago. I thought for sure it would help me, but it seems to me that I have everything correct. I have the .dll inside and everything, but every time I launch Isadora I get the error unfortunately. 

    My specs:

    Windows 10 Home, 16GB Ram, GTX1650 Max Q 4GB, i7-8565U

    I tried:

    Running with administrator, re-downloading, restarting Isadora, restarting the computer. 

    Please help if possible.

  • Tech Staff

    @anotherartist

    Hi there!

    Welcome to the Isadora community forum.

    It seems like you have the same issue that other users are reporting on the other thread. We would love to get to the bottom of this and fix it as soon as we can. To help with this we kindly ask you to send in a Support ticket at https://support.troikatronix.c... so that we can take a closer look at what is going on.


    Thanks for the effort!

    @DusX Could you take a look at this case?


  • Hi @juriaan

    Thank you so much for the directions. I will open the support ticket now.


  • @anotherartist said:

    Thank you so much for the directions. I will open the support ticket now.

    Dear @anotherartist

    I believe I have worked out the problem. When I tested the plugin on a fresh copy of Windows, I got the DLL error too. (I previously had tested on my development machine, which has extra files that allowed the plugin to run without error.)

    In any case, a new version has been uploaded as of 9:26 am Berlin time (3:26am EDT time) on April 24th. 2021.

    Please go to the OpenNI Tracker add on page, download the plugin package again (openni-tracker-win-v0.9.8b4.zip), and install the plugins as directed in the READ ME file. (I have not changed the version number, but the contents of the file are different.)

    When dragging the three plugins to the shortcut, please make sure to replace the existing plugins as directed in the READ ME.

    Report back here or in the ticket you opened if you have any trouble. I'm sorry for the inconvenience.

    Best Wishes,
    Mark


  • @mark

    Unbelievable. It's working and loading without any problem (hopefully stays that way). Thank you so much! (seriously you are the best!)

    Including a pic of it working just in case anyone else has this problem and is scouring the internet.


    Cheers,

    AA


  • @anotherartist said:

    Unbelievable. It's working and loading without any problem (hopefully stays that way). Thank you so much! (seriously you are the best!)

    Well, I am embarrassed that a non-working version was uploaded in the first place. So thank you for bringing this to our attention!

    Enjoy,
    Mark