[ANSWERED] Isadora freezes when I show stages on PC, but not on Mac


  • Isadora is freezing whenever I show stages on my PC. This happens in empty projects as well as the one I'm building. I've tried resetting the preferences, turned off all firewalls, uninstalled and reinstalled.  It's a gaming PC (does this make a difference?) with 32GB of Ram, an Nvidia 2060, and  i7-9700F CPU @ 3.00GHz.

  • Tech Staff

    Hi there @millslow

    That doesn't sound good! Let's get to the bottom of this. Could you open a support ticket at https://support.troikatronix.c..., our support team would be happy to assist. This way we can track the issue better / get the required details from you to see what is going on.

    Thanks !


  • @millslow in NVIDIA Control Panel try going to Manage 3D Settings and in there under Program Settings you need to select Isadora and make sure that it's running via your Nvidia 2060 instead of the intel processor.