Unable to start Isadora with NON "Pete" Free Frame plug-ins

  • Tech Staff

    I have had similar problems in the past although I don't remember the details.
    If you want to send me the files I can try to replicate the issue on my Win 7 64bit machine.

    ryan at plastikwrap dot com

  • Tech Staff

    I have not problem loading them under the latest Isadora version.

  • Darn. Thanks for trying!  No luck at my end at all.  I've tried lots of different things, but Izzy still crashes when I start her up.

    Clearly there has to be something different about my system, but I've tried it on 2 computers and it's the same problem.  I'm going to try it on a third now.



  • Tech Staff

    Did you try removing all freeframes, starting isadora.
    Closing it.
    adding just one of the 'other' freeframes (try each desperately) and starting Isadora?
    I have freeframes that crash izzy, but they are freeframe source plugins. (example is fugscope)

  • Dear DusX,

    I know that Hugh did that. The Pete's Plugins FreeFrame actors work fine, but as soon as he adds one of the others, it crashes.


  • Indeed I have.  I also tried the third computer - same problem.

    No idea what to try next.  Any thoughts?



  • i thought Freeframes did not work properly at all on 64 bit computers. They do not compile at all on ubuntu64 bit. just an idea


  • Interesting thought...

    DusX tried Win7 64 and it worked for him. I know Mark is doing the same, although he's running it on a MAC, which could make a difference....



  • Regarding this comment

    "i thought Freeframes did not work properly at all on 64 bit computers."
    Isadora is a 32 bit app, as are the FreeFrame plugins that run under it's control. The run in 32 bit mode on 64 bit Windows.
    Best Wishes,
  • Tech Staff

    I have put all my freeframe files into my director (I also have many),
    I can report that any freeframe source files (like fugscope) will crash Isadora on load.
    If I remove the source FF then Isadora loads and
    I receive reports of a number of them having ID conflicts.
    Once open my freeframes work, other than a few having bad video outputs (must be mixed in Isadora to show video) things are as expected.

    What exact version  are you running?. I have most installed on my machine, so I can test the version if not the latest release.

  • Tech Staff

    Your freeframes are also working for me in f24 (previous test were latest release)

  • Hi DusX,

    Thanks for your continued help!

    I haven't got f24 anymore so I'll have to download that and try it.

    I'm using 1.3.1 f03, but this has been going on for many versions before that! I'm guessing well before f24 (and on 3 or 4 different computers, too!).  Around September 2011, I believe.



  • Hmmm...

    I installed f24 on a non-production machine (but one that wouldn't run any non-Pete plugins) and Isadora will start and the 2 plugins that I've been using as an example both run and there's no crashing!  I haven't tried it on either of my production machines yet.

    @Mark - does this give you a hint?



  • Hello again, @Mark,

    So, I now have f24 on my production machine.  I placed all the non-Pete FF actors into a new FF directory, along with the Pete ones.  Started up Isadora and in Preferences changed the FF Plugin Directory to the new one.

    Isadora starts and gives the error message in picture 1 for each non-Pete plugin (45 times), but when it finally opens, they're all there and appear to function.

    However, when I try to load the show file that I've been working on, Isadora crashes and I get the usual Window message (picture 2).  I guess f24 doesn't automatically generate a crash report?  I tried loading an old file and I got the expected Izzy Update File message and then it crashed.

    Next, I tried changing the FF Folder back to the default, restarting Izzy and all is well with my show file.

    Next, I put the 2 plugins that I've try to use into the default FF folder and Isadora loaded just fine - no error messages and the actors are there.  However, once again, when I try to load the show file that I've been working on, Isadora crashes and I get the usual Window message (picture 2).

    I tried making a new show.  All was well until I tried to use those two infamous actors.  As soon as I placed one in a scene, Izzy crashed. (picture 2)  I tried it 2 different times - once with each of the actors - each with the same result.

    The funny thing is that I'm using them without issue on my other (non Production) machine! I've had both those actors running in a scene for the last hour.


    I hope all this info is helpful, Mark.



    113ad2-izzyfferror1.jpg e81611-izzy-stopped.png

  • Tech Staff

    Is Picture Player one of your freeframe plugins?
    This error is usually shown if you have duplicate plugins in your freeframe plugin path. (note 2 directory levels are searched I believe, so if you have copies inside another folder they may be read as well.)
    I get these errors every now and again when I move this about.. has always been duplicate file for me (I get 3 of them right now.. haven't had time to clear it up, but it doesn't crash me)

  • Dear Hugh,

    I'm in an airport and cannot give a long answer here. But, you shouldn't be getting that Picture Player error unless one of the FreeFrame actors uses that code (_pct) as it's "ID".
    Now, to be really sure, this is what I would do on your production machine:
    1) Uninstall Isadora
    2) Go to c:\program files and delete the whole Isadora folder to make sure it is really truly completely gone.
    3) Delete the preferences as described here: http://troikatronix.com/support/kb/delete-isadora-preferences/
    4) Delete (or at least rename) your FreeFrame folder so Isadora won't find it.
    5) Run Isadora. Is everything OK?
    6) Quit Isadora. Install Pete's Plugins and restart Isadora. Everything OK?
    7) Quit Isadora. Install your other FreeFrame plugins. Restart Isadora. Errors or OK?
    Also, make sure you have the vey latest version of QuickTime on all machines.
    That's what I can offer for the moment. Obviously there's something different about your production machine and your non-production machine. We'll just have to keep looking until we find out what that difference is.
    Best Wishes,

  • Thank you for your help, Mark.

    In this re-installation process, do you think it makes a difference that I have several versions on the machine? Should I delete them all? As I write this, I'm thinking that I should....



  • Hello Mark,

    I followed all the steps above and I uninstalled all 3 versions of Isadora on the machine and got rid of the FF folder and manually deleted other things left by the uninstaller.

    Restarted the machine.

    Installed vf03. Runs fine (including show files I tried)
    Installed Pete's Plugins. Runs fine
    added one extra of the example plugins. Crash. sent report.

    Did the above several times with both F03 and F24.  Same results as before.

    I did check the QT version, too.

    No change in status.



  • Ummmm. Yuk. OK. Well, I have nothing further to offer at the moment. I'll need to have a look at the crashes. I'm sorry this is taking so long to sort out, but given that it works on one machine of yours and not the other, it seems to be something special about the machine.

    Best Wishes,

  • It's nice to know I'm special....