Reliable Higher end PTZ cam



  • I just purchased a $1000 HuddleCam 10X USB camera to use with Isadora and Max/Jitter with the idea that the cam would provide superior image quality and the Pan/Tilt/10X zoom feature would allow me more flexibility with camera placement.  The image quality is indeed great and I can place the camera up to 30 feet from my dancers, but the video feed has proven completely unreliable.  Every time I stop live capture the signal is dropped and won't come back 'til I rescan.

    Has anyone used a higher-end USB PTZ camera that plays nice with Isadora?


  • Some questions to troubleshoot this a bit... I haven't used that particular camera, but have used quite a range of others.
    Are you on Mac or Windows? Which version of Isadora are you using?
    How are you "stopping" the Live Capture? Are you using the 'Capture Control' actor to stop/start the feed?
    If so, just to clarify, are you saying that the Capture Control actor is working as expected when told to stop the feed, but then will no longer respond to the trigger to start again, without having to go to the Live Input capture window and click the button to rescan devices?



  • I'm using a mac… actually I've tried it on 2 Macs: a MacPro via USB2 and a MacBookPro using USB3 (The camera is USB3) I'm using Isadora version 1.5.3f12 with the core video-add on on both machines.  Both Macs are running 10.8.5. I'm starting/stopping live video using the live capture settings dialog.  Just tried it with the capture control actor.  Triggering video the first time turns on capture properly.  Triggering "none" turns it off.  Triggering video again does nothing.  Must rescan to get it back, so it's exactly the same situation as when I'm using the settings dialog.

    I've also tried using the cam with Max/Jitter and it's even worse.  using jit.grab/jit.pwindow I get no feed.  If I bring up the system video settings window I can turn on the video feed from the camera, but as soon as I close the window it dies.  The next time I open the settings window I have to activate the built-in camera, then go back to the HuddleCam, at which point the feed is active again, but as soon as I close the window it dies.
    The cam does appear to work properly with the Messages app. which of course has caused the company I bought it from to say  that it's the fault of the "non-standard" software I'm using.
    I have no problems with the MBP built in camera in either Isadora or Max.
    thoughts?


  • BTW, Have you tried either the BigshotHD or Logitech C9000?  The company I bought the HuddleCam from has offered to trade mine for one of those but I obviously don't want to do it unless Isadora will be happier with it.



  • Can you try and capture the image with quicktimeX? It may be that the drivers are written for the newer capture system inside OSX.



  • Not sure what you mean…When doing live capture in Isadora I don't think I have any control over the version of Quicktime that's being used.  I would assume, however that  Isadora (and Max) are quicktimeX compliant, since it's been around since Snow Leopard (I'm running Mountain Lion))

    Or am I misunderstanding what you're saying?


  • Isadora uses the old quicktime 7 capture. You can open quicktimex and see if you can capture there.



  • I can capture in Isadora with no problem.  Where the problem arises is when I turn capturing off and then try to turn it back on.   The signal from the camera is lost when I stop capturing and I can't get it back without rescanning.  Also, since I use the real-time capture to feed plugins in performance, using Quicktime X doesn't do me any good inside Isadora. (By Quicktime X I'm assuming you mean the capture feature in the most recent version of Quicktime Player.)



  • Yes, sorry I misunderstood the trouble you were having, I thought the driver was not functioning, but it seems it is Isadora instead. Just to check do you have the save/load all settings when starting/stopping live input selected?



  • No luck.  At this point I'm pretty much convinced it's the camera, although if it is, as all the advertisements say, fully compliant with any application that supports USB video, I'm not sure what the story is.  (It's completely non-functional when I try to use it with Max/Jitter.)  Perhaps it's the USB3 aspect that's causing the problem…  Frustrating, because the image quality and PTZ features are a real plus.



  • What USB3 controller do you have? I know there are quite a few chips that do not really support the full bandwidth. Are you using a laptop? Do you have access to a desktop machine with a separate usb3 PCIE card. For high bandwidth applications these seem to be the only useable devices. There is a pretty good list of USB3 laptops that have full bandwidth controllers here http://forum.blackmagicdesign.com/viewtopic.php?f=4&t=4277&p=148443&hilit=usb+3#p148443

    It is for blackmagic compatibility, but the requirement is pretty simple, just full bandwidth and high performance. So far for me USB3 has been a little unreliable, (well not really but there are a lot of crappy controllers out there, including ones integrated into many motherboards.
    At any rate USB 3 has some pretty debilitating limitations on cable length (in my mind this kills the idea of a PTZ as you can only be a few meters away from the port for high bandwidth uses like HD video, as you could probably just reach and move the camera anyway).
    Take a look at something like this
    http://www.ebay.com/itm/10x-Zoom-High-Speed-1080P-HD-SDI-PTZ-Dome-Camera-IR-60m-1-2-7-CMOS-Auto-Focus-/261447245257?pt=US_Security_Cameras&hash=item3cdf785dc9
    It has a similar specs (possible the same sensor by the looks of it) and is HDSDI so easy cheap and long connections between camera and computer and SDi capture boxes are cheap.

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.