assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Possible IzzyMap Bug


  • Beta Gold

    Setup: I have two stacked projectors, one basically on top of the other, which I am trying to use to make a doubly-bright image for rear-projection. They are connected to a Mac Pro (Late 2013) similar to the one in my signature via VGA (and VGA-ThunderBolt adapters). I am using Isadora 2.1 with a USB dongle. I am using OS X 10.10.3. I had the two projectors manually focused so that one image was slightly larger than the other on all sides. I then used IzzyMap to pull in the corners and manipulate the images so that they overlapped. It worked extremely well. The patch is not at all complicated, it is literally just two picture player actors hooked up to two projector actors. (I was just making the template for the mapping so I could copy and paste it into a number of scenes.)
    Problem: The issue is that when I exit Isadora, turn off the projectors, or sometimes even just navigate to another scene, the mapping goes off and the images no longer overlap. 
    Details: The computer is finding the projectors as the same displays each time, and remembering the resolution to which I set them. Nothing is changing in the Isadora preferences tab either. Switching to a difference source and then back on the projectors does not do anything. I have multiple different versions of the scene with the mapping, as well as a few different versions of my patch where I just started the mapping over again, but it seems to be off in a different way each time. Sometimes I'll open it and an old scene will have the proper mapping and the new one will be off, sometimes it is the opposite, sometimes it just randomly switches. The troubling thing is that it is never consistent as far as I can tell. It will get "stuck" in one mapping, then change to another and get "stuck" in that one.
    What seems to help: (Neither of these actually solve the problem, they just fix it for a very short time.)
    1) After exiting Isadora and turning the projectors off, waiting, then turning them both back on, often (but not always) the mapping will be correct in the first scene in which I force stage preview. Sometimes it stays this way, and sometimes it changes the mapping and becomes off if I move to a different scene.
    2) Going into the computer preferences, display, and then changing the resolution of the projectors to a different resolution then changing them back always fixes it for the current scene, but when I change scenes the mapping always gets off again.
    Has anyone experienced anything similar with Izzymap? I've never had a problem like this before with it, and the most confusing thing is the inconsistency with which this issue is occurring and that it is happening in different ways.
    Any thoughts or suggestions would be very welcome.
    -Woland

  • Tech Staff

    Just out of interest what projectors are they? And are you connecting to them via DVI/HDMI or something else?

    We had similar problems when mapping at Glastonbury. We never really got to the bottom of it but we felt it was an EDID issue. 

  • Tech Staff

    @Woland

    This is difficult to find out without sitting infront of the computer itself. So I need a few screenshots that I can get a better overview.
    So please upload following screenshots:

    Isadora Preferences: Video tab and Stage tab

    Projector actors and the 2 Mapping Windows

    Best Michel


  • Beta Gold

    @Skulpture The projectors are Optoma W316ST DLPs. They belong to the company, and were purchased last year. They are connected to the computer via a 100' VGA and a VGA-to-Thunderbolt adapter each.

    @Michel I have attached screen shots. The videos that are going to be played from these projectors are 1366 x 768, which is why that resolution appears in a few places (Video Tab, Stage Tab, Mapping Windows). I used a 1920 x 1080 test image while mapping because it has the same aspect ratio and because I could not find a good 1366 x 768 test image. In regards to mapping, at first I was using a composite on both the input and the output and doing the tweaking mostly on the output. I then tried using a rectangle instead, and making the changes in the input instead, but got the same results, (the mapping did not stay put when things changed). I've also notice that the mapping doesn't distort when it becomes off. It stays the same shape, one image just becomes translated either left or right. With this in mind, I tried just adjusting the horizontal and vertical inputs on the projector actor itself to align the two images, as they were already the same shape but one was just translated, and it seemed like it fixed the problem. I tried it last night, but when I came back this morning the image was off again. It may be that I just have to use global values to tweak all of my projector actors' vertical and horizontal values before every rehearsal/show.

    e6640e-screen-shot-2015-12-14-at-9.33.17-am.png 9eea5d-screen-shot-2015-12-14-at-9.33.36-am.png 5c6caa-screen-shot-2015-12-14-at-9.34.21-am.png 011127-screen-shot-2015-12-14-at-9.35.54-am.png cfa882-screen-shot-2015-12-14-at-9.36.30-am.png



  • @Woland,

    i made the experience that the projector "calibrates" the vga input every time you switch them on
    the "calibration" is a kind of finding the first pixel of information and adjusting the phase etc settings
    thats why you should have this projector settings in your vga input and not with a dvi connection
    you could try to send a full white image (like a white desktop background) and turning on the projectors
    so they "see" the whole 1366 x 768 picture
    best clemens

  • Tech Staff

    @Woland

    What @m_theater says could be a very good hint to find the problem, how to get exactly the same settings every time. One thing you can try to hit some kind of auto image (does the optomo provide something like that?) with the test image in fullscreen.

    Best Michel


  • Beta Gold

    Hello,

    I had the same problem for a video installation in Avignon some years ago, with Optima…
    Yes, the beamer try to scale the available image at startup, my way to turn around was first launch computer with Isadora sending a full white image, then start the beamers and later send the patch with mapped images. It was done automatically and worked for a month.
    Jacques

  • Beta Gold

    @m_theater @Michel @jhoepffner
    Thank you very much! Sending the full-sized, unmapped, white image first, then powering up the projectors, then sending the patch with the mapped images solved the problem completely.


  • Tech Staff

    Im glad this works but don't understand why this is happening in the first place.


  • Beta Gold

    @Skulpture

    It's because this sort of beamer is intended for office usage, so it try to optimize the incoming image.


  • these beamers also have a re-sync button on the remote.


  • Beta Gold

    @dbini Thanks, I actually had not noticed that.


  • Tech Staff

    I'm glad you got this sorted. I am making note of this important piece of information. It's sure to help many others. Including myself ;)


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.