assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Possible Picture Player Bug? Picture player not outputting



  • We have a show built for the most part, and then without much explanation all of our picture player actors stopped outputting their content.  It works in a new show file so it's show file specific. I don't believe it's systemic or related to the content. The problem occurs on multiple computers.  Am I missing something?  Is there a global picture player setting somewhere?

    I attached the show file 

    25f45d-fh2e-izzy.izz



  • Isadora 2.2.2

    Macpro 6 core and Macbookpro Retina 

  • Tech Staff

    @AshChristopher

    I am able to reproduce this issue on my machine with your file.
    Please create a support ticket (link in my signature) and I will do my best to find the cause of this for you.


  • Great.  I will make the ticket.  We have a theory it might have coincided with a recent addition of a "preload scene" actor.



  • We have a workaround where we are changing all of the stills to one frame movies.


  • Tech Staff

    @mark

    Can you take a look at the attached izzy file.
    Simply link the mov's to any mov, and the png's to any png.
    Check any scene with picture players, and you will see that there is no output.
    Additionally, if you import a picture, and try to drag and drop it to the scene, no output.
    It appears the file is corrupt in some way. I am able to reproduce the Issue on PC, where AshChristopher is experiencing it on Mac.
    very strange.


  • Maybe I had a same problem on my PC and found that large-size(more then ~2000x2000) pictures cause picture player to stop working correctly. It can't load new pictures and doesn't produce any gpu-stream. So each time I have to check all pictures for size, and then down scale all large-size images. Maybe it is same issue on Mac. Just my assumption.



  • I am also having trouble with PicturePlayer not working as expected after resizing projector output, from a single projector to a four projector (2x2) blend with 200% zoom on each.


  • Tech Staff

    Please submit a bug report. It will be especially helpfull if you can supply a isadora file that demonstrates the problem. The link is in my signature.



  • hi,

    was this ever resolved? I have the exact same issue.

  • Tech Staff

    Are you experiencing this issue?
    If so please submit a bug report (link in my signature) and we can look into it right away.



  • Dear @DusX & @AshChristopher,

    I'm sorry that I did not see this earlier. But the problem is simple: the file has YUV Mode enabled in the file you attached. (We really need to remove this from Isadora, as it is no longer viable.)
    You shouldn't be using YUV mode with v2.0.
     If you turn of YUV mode (**File > Disable YUV) **the PNGs immediately loaded as expected for me.
    Could that be the case for you too @wassarts?
    Best Wishes,
    Mark