Realsense D435 Not Resolving on macOS Big Sur

  • Hi,

    I've downloaded and successfully the script (see attached image). I still can't get past "resolving" when I open the Openni Tracker. I've also increased the init time and double-checked connections. The camera still doesn't come up as a device option in the video input menu. Any suggestions would be greatly appreciated! I'm stumped...and admittedly new to this....!

  • @emullis forgot: I'm using mac OS Big Sur 11.2.1

  • Izzy Guru


    Did you download the newest Isadora version 3.0.8, because 3.0.7 is not compatible with Big Sur. Please also add your hardware and software specs along this guide:


    Best Michel

  • @michel thank you for your response.

    I am running Isadora 3.0.8.
    macOS Big Sur 11.2.1
    MacBook Pro (13-inch, 2017, 2 thuderbolt 3 ports) 8 GB Memory
    INTEL Realsense Depth Camera D435 right out of the box 

    thank you for your consideration! e.

  • Izzy Guru


    OK, thanks. I don't have a real sense my self so I can't help you with any steps. Maybe someone else can answer. @DusX?

  • @michel Thank you! Any suggestions would be appreciated. I'm trying to get this working for a dance tech class here in Taipei. 

  • Tech Staff

    I have just run a few tests. First I updated my D435 firmware again, so its current.
    Then I confirmed that the device is working in 3.0.8 on Windows 10. Everything worked as expected.
    I moved to macOS BigSur, and tested again. I also was unable to get a camera feed, using either the Live Capture system or the OpenNI actor.

    After digging around a bit, I found on Github that it seems the RealSense SDK is supported on macOS upto High Sierra.

    I was hoping to find a RealSense viewer application (one exists for Windows) so that I could try to test in another application, but I have not been able to find such a utility yet.

  • @emullis

    So I have done some investigating on Big Sur 11.2.3, which is the latest version.

    First, I want to ask you if you're expecting the RealSense D435 to show up as a web cam on macOS, because that is not something I would expect to work. I did some searching on the web, and nowhere did I see that this was possible. If you have different information on this, please let me know. (On the Intel website, they offer a driver for the RealSense on Windows; but do not offer an equivalent on macOS.)

    As for tracking: the RealSense updater offered in this thread works fine under Big Sur. I updated my camera to the latest firmware 5.12.11 without any problems.

    However, as you said, I cannot get OpenNI Tracker to find the camera under Big Sur. (It does however work with Mojave, even after the firmware update.) So there is something going on that needs to be investigated for Big Sur.

    If I install the "package system" Homebrew and use it to install two libraries (libusb and glfw3) that are referenced when building the librealsense SDK examples, the examples open and run fine. This proves that communication with the camera is possible under Big Sur. Hopefully this means that  @DusX's assumption that there is not support for the RealSense D435 after High Sierra is incorrect.

    The next step will be to compile and run OpenNI Tracker on Big Sur so I can debug the system and hopefully figure out what's going wrong.

    I will update you all here when I know more.

    Best Wishes,

  • @mark any updates on this?
    thank you for looking into it. 🎵

  • @emullis said:

    any updates on this?

     I got slammed with finishing up the 3.0.8 release, so no further progress at the moment. I'll be able to get back into this over the Easter weekend hopefully.

    Best Wishes,