IsadoraSDK and IsadoraCore 1.3.0f24



  • I'm running into issues with building a C/C++ plugin for IsadoraCore 1.3.0f24 (same issue with Isadora 1.3.0f22) using the sample Xcode projects provided on the Troikatronix web site.
    I'm using an Intel Core2 Duo, Mac OS 10.6, Xcode 3.2.6.
    Downloading the most recent IsadoraSDK from the Troikatronix web site, the Xcode projects will build with no modification other than pointing the project to the library and Includes directories, but when I launch IsadoraCore 1.3.0f24 I get the message that the plugin will not load because it is not compatible with this version of Isadora.
    I've tried just about every combination of MacOSX SDK  (MacOSX10.4u.sdk / MacOSX10.5.sdk / MacOSX10.6.sdk), various architectures (i386, ppc, native, 32-Intel, 64-Intel), various compilers (gcc 4.0, gcc 4.2, the more recent LLVM compilers), and various Mac OSX targets (Mac OSX 10.4, Mac OSX 10.5, Mac OSX 10.6).  But none of them produces a plugin that will load.
    (I have also tried compiling for 64-bit Intel, but the IsadoraDemoPlugin fails to compile then because of a type definition problem in the image buffer class.)
    Can someone let me know what the correct compiler/SDK settings should be, so I can rule those out as the source of the problem?  
    Thanks,
    --Bruce

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.