Isadora v2.5 - Final Candidate (v2.4.5b09) is available



  • Dear All,

    For those of you working with the v2.5 beta, please download the latest version which I've posted today.
    http://troikatronix.com/isa25beta
    In addition to several bug fixes, you'll see the new icon and associated graphics that we'll introduce with v2.5.
    Best Wishes,
    Mark

    24e5b9-isadora-splash.png


  • Tech Staff

    Love the new graphics



  • Hi,

    @mark
    I'm getting 2.4.5b04 when using your link. Not 2.4.5b09 .
    Any idea ?
    Thanks
    Mehdi


  • @keftaparty

    Hi Mehdi

    I had that... and then refreshed my browser, which then gave me the correct description and links.

    HTH

    Mark



  • Yes please refresh your page, then it should show correctly. I have just tested this now and it works.  5d504f-screen-shot-2016-09-14-at-11.26.13.png



  • Hi,

    I have generated a patch from scratch in 245b09. However, the Force Stage Preview most often crashes the application.

    cheers
    bonemap




  • Hi,

    Attached is the patch that crashes the application when attempting Force Stage Preview. It could be how I have my system configured but just in case the patch files are here for reference.
    regards
    bonemap

    73913f-bonemap_videocapturegrid_crash.zip



  • Dear @bonemap,

    I used the built in web-cam on my Mac Pro, started the capture process, and repeatedly did Force Stage Preview with no problems.
    What is your camera source? Also the built in web cam? 
    The crash report you sent shows the crash is coming from the 3D Projector, which is rendering to the Virtual Stage.
    @mc_monte and @DusX can you please try this on your Mac OS systems to see if you get a crash also?
    Best Wishes,
    Mark


  • @mark, Yes, the built in MBP webcam. Cheers Bonemap


  • Tech Staff

    @mark and @bonemap I tried it and have no crash

    running Isadora 2.4.5b9

  • Tech Staff

    @bonemap

    We could re-create the crash, Mark is working on it.
    Best Michel


  • Indeed - we all worked on it this morning. :)

    I managed to re-create it too.


  • I have a big crash this morning but after research I found the culprit and the way to get around.

    A patch last saved with 2.2.2 crashed all the more recent apps (mainly 2.4.5b9, but also the apps between), after many test, I found that the title of a stage, activated when entering the first stage, had a title with french accent: "lumières", when I changed it to no accent word: "light", all worked perfectly.
    perhaps a side effect of the UTF8 implementation? Or another sign of globish empire?
    Glad it's working now.
    Jacques


  • Hello,

    I continue trying to debug 2.4.5b9, now it's the controls who provoke the crash.
    If I save in 2.2.2 without controls, it works. If I recreate it (8 sliders, 16 edit text, 24 buttons), when I exit the edit mode, it crashes.
    There is no accent, only pure ASCII letters. I try to know where is the problem, not successfully at the moment.
    One think very annoying when you crash is when you restart, the app try to relaunch the faulty patch and boom! it recrashes. The only way is to trash the izzy preferences, as to have an empty patch, not the crashing one.


  • Even trashing the preferences, it try to relaunch the faulty patch and recreates again…



  • The only way to restart Isadora is to trash the faulty patch…



  • Please forgive me for the monologue!

    That was working in 2.2.2 but since 2.2.3 (UTF8 in Javascript), no
    Finally, all is due to the bloody french accents since the UTF8 implementation.
    – first it doesn't accept stage name with accents – crash
    – second it doesn't accept to feed Edit text from Trigger Text actor with accent – crash
    – third it doesn't accept text with accent in Radio Button – first only the lines without accent appear, then it crashes.
    I try to suppress all the accent in my patch and I say you if it works properly.
    Jacques

  • Tech Staff

    @mark @bonemap I was also able to recreate the crash now: had to wait till about 15 vides where triggered and the force stage preview...



  • finally, without accents, all is working properly

    Jacques

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.