assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Hap Direct Show windows problems



  • I am experiencing a few issues with Isadora on windows with HAP direct show playback. 

    Firstly, I am using a razor blade 2016 with a GTX 1060 and a high speed m2 drive and playing a 3840*2160 50 fps hap file. When I use the nvidia manager to set Isadora to use the high performance nvidia card Isadora will launch once and then will not lauch again until I restart. Leaving the graphics processor set to integrated will solve this, but I wanted to force Izzy to use the nvidia card. 

    Next, I get flickering on all forms of DS playback with just a movie and projecctor in a single scene. If I play the movie with Media player or quicktime for windows it plays fine. If I switch Isadora to not use native playback for AVI it also plays fine, albeit with much poorer performance. However, here is the key to the problem, if I add a GPU processing actor, like flip between the player and projector even without flipping the image the flickering is gone.

    The performance increase in DS HAP playback is sunstantial and worth the effort, it would be great if this could be smoother and loose the flicker (which is kind of random). I have a feeling the two things are connected somehow.

    To be sure I am making the files with virtual dub (great tip @DusX). I am trying audio files with 7.1 audio, but am also testing with just stereo audio. The audio is uncompressed PCM at 48k and my soundcard is set to 48k as well.

    I am using Isadora 2.5.1 and windows home 64 bit version 1703 build 15063.296 and nvidia driver 382.05 (latest).

    I have filed a bug report as well. 

    Fred

    Fr


  • Tech Staff

    @Fred

    I have recently experienced a few issues as well. Not always reproducible, but pretty regular.
    I am testing, but should be submitting test files and a reproduce later today.
    The flickers/glitches I am seeing seem to be caused by position/speed changes. Is this a factor for you as well?



  • @DusX no I just play the file and it flickers. Using a flip actor doing nothing in between fixes it. I saw something like this when I had incorrectly set double buffering on open gl....


  • Tech Staff

    @Fred
    Interesting. Thanks



  • @Fred @DusX

    I have no software that will allow me to compress HAP on Windows. I suspect this problem shows up for high resolution clips, and I can't make one. Is there a way to get a short (10 sec) high resolution clip that might allow me to reproduce this issue?

    In the meantime, it seems that adding a GPU actor after the output solves the problem, right? I would use that as a workaround until I can offer you a real solution. (Perhaps it's a good idea to put this GPU actor inside a user actor; then you can then edit the User Actor to remove the GPU actor later to get rid of the extra copy.)

    Best Wishes,
    Mark



  • @mark here you go, there is one with 8ch audio and one with 2ch


    https://www.dropbox.com/sh/2u8...


  • Tech Staff

    @mark

    There are also, many test files at: PathToIzzyCloud\ISADORA\QAandSupport\Media


  • Tech Staff

    @Fred

    Thanks Fred. Very helpful. I have added these to our test file base.



  • @mark Keeping the flip in is my solution for the moment, but with flip I get around 70 cycles and without I get 200, so for this project at this stage it is OK (I am just planning and designing), but I have a month to get it going and am a bit nervous about these glitches getting solved in time.



  • @DusX Out of curiosity, did you try these files? Do you also get the flickering?



  • @Fred said:

    cycles and without I get 200, so for this project at this stage it is OK (I am just planning and designing), but I have a month to get it going and am a bit nervous about these glitches getting solved in time.

     If you can get me 10 seconds of test file I'll solve it before you're show. Send me an email about this and we'll figure out a way.

    Best,
    Mark

    P.S. I've also downloaded the open source compressor created by Render Heads. I want to figure out why a normal HAP movie is twice as big on PC as on the Mac.



  • I have tried with 2.5.2 and it plays the file ok, when I launch isadora after installing, this is with the preferences set to 30 fps. Once I bring the framerate up and the srervice tasks to 4 then the flashing comes back. Using an inactive flip actor still solves this.



  • @Fred said:

    alling, this is with the preferences set to 30 fps. Once I bring the framerate up and the srervice tasks to 4 then the flashing comes back. Using an inactive flip actor still solves this.

     Dear Fred,

    We were too close to the release to fix this for v2.5.2, as it might have introduced show-stopping bugs. It is now at the top of our priority list.

    Best Wishes,
    Mark


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.