Forum Update - Everyone Please Read [UPDATED Apr 13, 2018]


  • @Woland,

    First, fantastic find regarding the workaround for the editor problem. Thank you. 

    Second, to everyone, I'm sorry for the trouble. As I said originally, we had no choice but to move to the latest build b/c of all the crashes.

    Regarding the reply problem, which I can see easily on Safari, Firefox and Chrome

    I have submitted a bug report on NodeBB's github as you can see here:

    https://github.com/NodeBB/Node...

    I've also posted about it in their forum in the bug reports section:

    https://community.nodebb.org/t...

    But since I don't have a smartphone, if you feel the toolbar issue people have mentioned is different than the one I submitted, can I ask you set up a github account (if you don't already have one) and submit a detailed description of the bug there and also to post it on NodeBB's forum. 

    Thanks for handling this Lucas. ;-)

    Best Wishes,
    Mark

  • Tech Staff

    @mark 

    Note that on long original posts like the one linked below, my workaround is useless because one needs to scroll down to far in order to reply to the original post.

    Also, sometimes I'm getting the reply window in the right place, but all the formatting buttons are mysteriously absent. 

    Discarding the current reply window and trying again usually brings the formatting buttons back.

    https://community.troikatronix...

    Edit:

    Workaround for Replying to Threads with Long Original Posts. 

    1) Zoom browser view out (until the "reply" button and the top of the first post are both visible).

    2) Reply to the original post.


  • @woland said:

    Note that on long original posts like the one linked below, my workaround is useless because one needs to scroll down to far in order to reply to the original post.

     Well, this workaround works for me, regardless of the number of posts:

    1) Hit reply button... editor fills the frame, etc.
    2) Hit the little red button with the "speech balloon" and three dots to hide the reply
    3) Scroll to the first post
    4) Hit the red button again
    5) Now you can successfully enter text, apply formatting, etc.

    Best Wishes,
    Mark

  • Tech Staff

    Worth noting that the the fix above doesn't work for editing one's own replies.

    Best wishes,

    Woland

    Edit: I was wrong. It does work for editting one's own replies.

  • Tech Staff

    Workaround for Replying to Threads with Long Original Posts. 

    1) Zoom browser view out (until the "reply" button and the top of the first post are both visible).

    2) Reply to the original post.


    Edit: Mark's workaround is better.


  • Dear Community,

    So, the NodeBB folks finally came up with a patch that at least solves the problem where you can't reply unless you're at the top of the forum list. This works for me on multiple browsers.

    But what about people on with phones? Is the toolbar appearing in the right place now and working for you?

    @DusX @mc_monte @Woland please report back.

    Best Wishes,
    Mark

  • Beta Platinum

    @mark

    Hi,

    I can report that the navigation elements still do not function at all on iOS Safari, iPhone 8. But the reply function is working well.

    Best wishes

    Bonemap 

  • Beta Platinum

    @mark,

    Hi,

    I have switched to an iPad using iOS, safari, and all navigation options appear to function as expected. Therefore, the dysfunctional interface occurs for me only with the smaller screen layout. The forum CSS styles responsive to display ratios might need the parameters for smartphones to be further adjusted and tested. 

    Look forward to seeing this resolved.

    Best wishes

    Bonemap

  • Tech Staff

    I have the same experience as @bonemap 


  • HI All !! I cant do posts.It says I dont have enough privilegies for that action. Im on Safari. Any ideas?? Thanks a lot

  • Tech Staff

    @ril

    Perhaps try refreshing the page and make another attempt? Failing that, could you please try a different browser (Chrome, Firefox) and see what happens?

    I checked your account in the Admin panel and it doesn't look like there is any reason you shouldn't be able to post.

    Best wishes,

    Woland


  • Thanks @woland I had tried from Chrome from my cell phone and its the same situation.


  • @woland see the screen capture when i tried to start a new post appears this red pop bubble on the left corner


  • @woland cant up load the file sorry !!

  • Tech Staff

    @Michel 

    Any ideas?

  • Tech Staff

    @ril

    Does it work now? Just asking because I see you have posted this (https://community.troikatronix...) after the above posts.

    Best Michel


  • @michel 


    Hello Michel ! the last weeks I have not been able to post. Yesterday I went back to configure my forum user and I could make a post. Then I tried to do another one but in Spanish and I could not. Obviously something does not work well for me.

  • Tech Staff

    I can't seem to add files.


  • @dusx

    Attempting to add a file.

    Here's a picture.

    That works. 

    But I can't add a .zip or a .izz file.

    Will go check this.

    Best,
    Mark


  • OK, the file upload is a problem. It's yet another bug in the new version. :-(

    I've alerted the NodeBB folks in this bug report.

    I'm sorry to everyone for the inconvenience of all this.

    Best Wishes,
    Mark